Synology DSM 7.0.1-42218

Geplaatst in:

Synology heeft de eerste bugfix-update uitgebracht voor DSM 7. Het gaat om versie 7.0.1 met buildnummer 42218 met daarin een hoop problemen die opgelost zijn, waaronder ook een aantal ernstige beveiligingsproblemen. Zo is in deze versie OpenSSL geüpgraded naar versie 1.1.1l. Ook bevat deze versie ondersteuning voor datadeduplicatie van de schijf. Die functie werkt alleen in combinatie met btrfs en Synology-ssd’s. Synology DSM, oftewel Disk Station Manager, is het besturingssysteem voor de nas’en van Synology. Het is een erg gebruiksvriendelijk besturingssysteem waarmee je eenvoudig je nas kunt beheren.

Downloaden

Je kunt je Synology als volgt updaten. In DSM ga je naar het Configuratiescherm. Klik dan op Bijwerken en herstellen en wacht even totdat DSM meldt of er een update beschikbaar is of niet. Als je automatische updates aan hebt staan, hoef je natuurlijk niet op updates te controleren. Om dat in te schakelen, klik je in dit scherm op Instellingen voor bijwerken. Selecteer dan De nieuwe update automatisch installeren en stel een schema in.

Je kunt ook het updatebestand handmatig binnenhalen. Daarvoor selecteer je hier je NAS en download je het updatebestand. Ga naar DSM in de pagina om op updates te controleren. Kies voor Handmatig installeren, blader naar het gedownloade pat-bestand en volg de stappen om te updaten.

Screenshot van DSM 7.

Changelog

What’s New

  1. Supports migrating SA3200D system configurations when users perform HDD migration.
  2. Added support for memory cache mirroring across controllers for better data consistency on SA3200D.
  3. Added support for the “Sync remote mounted folders” option for Shared Folder Sync.
  4. Supports creating volumes of up to 1 PB in Btrfs (Peta Volume) format on the XS/XS+, SA (SA3200D excluded), and FS-series models. (Learn more)
  5. Added support for data deduplication on Btrfs volumes on certain models. (Learn more)
  6. Supports notifying users when there is insufficient storage for metadata.
  7. Updated OpenSSL to version 1.1.1l to fix multiple security vulnerabilities (CVE-2021-3711, CVE-2021-3712).

Fixed Issues

  1. Fixed an issue where DSM might not automatically reconnect to a VPN after disconnection.
  2. Fixed the sorting issue on the View Details page in Resource Monitor > Performance > Disks when a USB drive is connected.
  3. Fixed an issue where the display in Volume Settings in Storage Manager was incorrect once users pinned the desktop widgets.
  4. Fixed an issue where the throughput in Resource Monitor might not be displayed correctly when the system network traffic or the throughput of disks or volumes was heavy.
  5. Fixed an issue where when users used third-party extensions to change the DSM theme, they couldn’t customize the wallpaper.
  6. Fixed an issue where when non-administrator users shared files with password-protected links, the file names were displayed incorrectly.
  7. Fixed an issue where a healthy drive might be falsely detected as malfunctioning after it was swapped with a failed drive in the same storage pool when the system was shut down. The issue would cause the degraded storage pool to crash or become missing.
  8. Fixed an issue where users couldn’t import Docker container configuration files from local computers.
  9. Fixed an issue where certain packages couldn’t be installed when the built-in “DSM UI Compatible 6.x” package is missing.
  10. Fixed an issue where package statuses might be stuck at “Getting Status” in Package Center.
  11. Fixed an issue where filters might not work when users edit domain user or group privileges at Control Panel > Application Privileges.
  12. Fixed an issue where Security Advisor didn’t apply the security baseline setting for the first scan.
  13. Fixed an issue where users given the “Local user and management” privilege couldn’t perform the assigned actions.
  14. Fixed an issue where users who had taken snapshots of a shared folder couldn’t disable the usage detail analysis of the shared folder’s volume in Storage Manager.
  15. Fixed an issue where automatic configuration backup might fail under certain conditions.
  16. Fixed a security vulnerability regarding GhostScript used by AirPrint. (CVE-2021-3781).
  17. Fixed multiple security vulnerabilities. (Synology-SA-21:25)